aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <thabogre@gmail.com>2021-08-03 15:24:19 +0000
committerterminaldweller <thabogre@gmail.com>2021-08-03 15:24:19 +0000
commitb20f83543a76fc1237a9030fefd81fb862685708 (patch)
tree31d0da2e87586240fe4a655105b2f45c08580be9 /pyproject.toml
parentsome clean up per lgtm (diff)
downloaddelf-b20f83543a76fc1237a9030fefd81fb862685708.tar.gz
delf-b20f83543a76fc1237a9030fefd81fb862685708.zip
pep-8 and poetry
Diffstat (limited to '')
-rw-r--r--pyproject.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..9b8f034
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,16 @@
+[tool.poetry]
+name = "delf"
+version = "0.1.0"
+description = ""
+authors = ["terminaldweller <thabogre@gmail.com>"]
+license = "GPL-3.0"
+
+[tool.poetry.dependencies]
+python = "^3.8"
+capstone = "^4.0.2"
+
+[tool.poetry.dev-dependencies]
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"