aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 20 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9b8f034..e71a89e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,16 +1,33 @@
[tool.poetry]
name = "delf"
-version = "0.1.0"
-description = ""
-authors = ["terminaldweller <thabogre@gmail.com>"]
+version = "0.1.2"
+description = "yet another elf dump tool"
+authors = ["terminaldweller <devi@terminaldweller.com>"]
license = "GPL-3.0"
+keywords = ["elf", "capstone"]
+classifiers = [
+ "Environment :: Console",
+]
+include = [
+ "LICENSE",
+]
[tool.poetry.dependencies]
python = "^3.8"
capstone = "^4.0.2"
+[tool.poetry.scripts]
+delf = "delf:main"
+
[tool.poetry.dev-dependencies]
+[tool.poetry.group.dev.dependencies]
+mypy = "^1.6.1"
+pylint = "^3.0.2"
+bandit = "^1.7.5"
+ruff = "^0.1.1"
+black = "^23.10.0"
+
[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"