aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <thabogre@gmail.com>2021-07-29 11:41:20 +0000
committerterminaldweller <thabogre@gmail.com>2021-07-29 11:41:20 +0000
commitfab529b1c0bc71fa4c904e7a251038426f81369f (patch)
treea75317cae4dfab07e5042067d1246516f89a44c3 /pyproject.toml
parentfirst commit (diff)
downloaddevourer-fab529b1c0bc71fa4c904e7a251038426f81369f.tar.gz
devourer-fab529b1c0bc71fa4c904e7a251038426f81369f.zip
no need for externally getting the links. devourer can do that on its own now. using poetry now. added a dockerfile.
Diffstat (limited to '')
-rw-r--r--pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..f91a38f
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,17 @@
+[tool.poetry]
+name = "devourer"
+version = "0.1.0"
+description = ""
+authors = ["terminaldweller <thabogre@gmail.com>"]
+license = "GPL3.0"
+
+[tool.poetry.dependencies]
+python = "^3.8"
+newspaper3k = "^0.2.8"
+beautifulsoup4 = "^4.9.3"
+
+[tool.poetry.dev-dependencies]
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"