aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/040_link_gcc45.patch
diff options
context:
space:
mode:
authorTatsuya Kinoshita <tats@vega.ocn.ne.jp>2011-05-04 07:45:29 +0000
committerTatsuya Kinoshita <tats@vega.ocn.ne.jp>2011-05-04 07:45:29 +0000
commit2945f70be161735bf7efaefde43125a9ad3a4c88 (patch)
treeda85d4bca39cba5a7c4e6714c8b73d6a8cd547fe /debian/patches/040_link_gcc45.patch
parentReleasing debian version 0.5.2-10 (diff)
downloadw3m-2945f70be161735bf7efaefde43125a9ad3a4c88.tar.gz
w3m-2945f70be161735bf7efaefde43125a9ad3a4c88.zip
Releasing debian version 0.5.3-1debian/0.5.3-1
Diffstat (limited to 'debian/patches/040_link_gcc45.patch')
-rw-r--r--debian/patches/040_link_gcc45.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/040_link_gcc45.patch b/debian/patches/040_link_gcc45.patch
new file mode 100644
index 0000000..1b034b4
--- /dev/null
+++ b/debian/patches/040_link_gcc45.patch
@@ -0,0 +1,15 @@
+Description: Explicitly link w3mimgdisplay with -lX11 to build with gcc 4.5
+Author: Martin Pitt <martin.pitt@ubuntu.com>
+Bug: https://sourceforge.net/tracker/?func=detail&aid=3126430&group_id=39518&atid=425441
+
+--- w3m-0.5.3.orig/Makefile.in 2011-01-04 18:22:18.000000000 +0900
++++ w3m-0.5.3/Makefile.in 2011-02-06 12:05:40.000000000 +0900
+@@ -199,7 +199,7 @@
+ $(CC) $(CFLAGS) -DDUMMY -c -o $@ $?
+
+ $(IMGDISPLAY): w3mimgdisplay.o $(ALIB) w3mimg/w3mimg.a
+- $(IMGLINK) $(CFLAGS) -o $(IMGDISPLAY) w3mimgdisplay.o w3mimg/w3mimg.a $(LDFLAGS) $(LIBS) $(IMGLDFLAGS)
++ $(IMGLINK) $(CFLAGS) -o $(IMGDISPLAY) w3mimgdisplay.o w3mimg/w3mimg.a $(LDFLAGS) $(LIBS) -lX11 $(IMGLDFLAGS)
+
+ w3mimgdisplay.o: w3mimgdisplay.c w3mimg/w3mimg.h
+ $(CC) $(CFLAGS) $(IMGCFLAGS) -o $@ -c $(srcdir)/w3mimgdisplay.c