aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/100_use-cppflags.patch
diff options
context:
space:
mode:
authorTatsuya Kinoshita <tats@vega.ocn.ne.jp>2012-05-19 08:21:03 +0000
committerTatsuya Kinoshita <tats@vega.ocn.ne.jp>2012-05-19 08:21:03 +0000
commitad797e531290412a6981c2b199a1c9ec94221c91 (patch)
treeb898da8e187e4ea1c4333517251c700c1d6f25af /debian/patches/100_use-cppflags.patch
parentRelease Debian version 0.5.3-7 (diff)
downloadw3m-ad797e531290412a6981c2b199a1c9ec94221c91.tar.gz
w3m-ad797e531290412a6981c2b199a1c9ec94221c91.zip
Fix CPPFLAGS hardening flags missing (closes: #665491)
Patch from <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665491> provided by Simon Ruderich.
Diffstat (limited to 'debian/patches/100_use-cppflags.patch')
-rw-r--r--debian/patches/100_use-cppflags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/patches/100_use-cppflags.patch b/debian/patches/100_use-cppflags.patch
new file mode 100644
index 0000000..0b76fb2
--- /dev/null
+++ b/debian/patches/100_use-cppflags.patch
@@ -0,0 +1,17 @@
+Description: Use $(CPPFLAGS) with $(CPP)
+ Use CPPFLAGS from environment (dpkg-buildflags).
+ Necessary for hardening flags.
+Author: Simon Ruderich <simon@ruderich.org>
+Bug-Debian: http://bugs.debian.org/665491
+
+--- w3m-0.5.3.orig/Makefile.in
++++ w3m-0.5.3/Makefile.in
+@@ -150,7 +150,7 @@ parsetagx.o: html.c
+
+ funcname.tab: $(DEFUNS)
+ (echo '#define DEFUN(x,y,z) x y';\
+- sed -ne '/^DEFUN/{p;n;/^[ ]/p;}' $(DEFUNS)) | $(CPP) - | \
++ sed -ne '/^DEFUN/{p;n;/^[ ]/p;}' $(DEFUNS)) | $(CPP) $(CPPFLAGS) - | \
+ awk '$$1 ~ /^[_A-Za-z]/ { \
+ for (i=2;i<=NF;i++) { print $$i, $$1} \
+ }' > $@.tmp