aboutsummaryrefslogtreecommitdiffstats
path: root/fm.h
diff options
context:
space:
mode:
authorFumitoshi UKAI <ukai@debian.or.jp>2002-04-24 18:29:35 +0000
committerFumitoshi UKAI <ukai@debian.or.jp>2002-04-24 18:29:35 +0000
commit4e8c85a7fa218fc538aaf3a4e08ffa9fd6017a3d (patch)
treec4b80e2b654ac6a89ac9abececae7ba701b15fac /fm.h
parent[w3m-dev 03181] KEYBIND_SRC was not passed to scripts/Makefile (diff)
downloadw3m-4e8c85a7fa218fc538aaf3a4e08ffa9fd6017a3d.tar.gz
w3m-4e8c85a7fa218fc538aaf3a4e08ffa9fd6017a3d.zip
[w3m-dev-en 00730] Re: Patch for a more flexible dictionary lookup
* NEWS: rc: use_dictcommand, dictcommand * main.c (execdict): use url_quote_conv() instead of cURLcode() * proto.h (cURLcode): deleted * doc-jp/README.dict: updated From: Fumitoshi UKAI <ukai@debian.or.jp> [w3m-dev-en 00729] Re: Patch for a more flexible dictionary lookup * config.h.dist (DICT): define * configure (use_dict): default y * fm.h (DICTCMD): deleted (UseDictCommand): added (DictCommand): added * main.c (execdict): rewrite to use DictCommand, loadGeneralFile() * rc.c (CMT_USE_DICTCOMMAND): added (CMT_DICTCOMMAND): added (params1): use_dictcommand, dictcommand added * doc/README.dict: updated From: Tushar Samant <scribble@pobox.com>
Diffstat (limited to '')
-rw-r--r--fm.h7
1 files changed, 5 insertions, 2 deletions
diff --git a/fm.h b/fm.h
index d3f7e78..274e8b0 100644
--- a/fm.h
+++ b/fm.h
@@ -1,4 +1,4 @@
-/* $Id: fm.h,v 1.58 2002/03/29 16:39:37 ukai Exp $ */
+/* $Id: fm.h,v 1.59 2002/04/24 18:29:35 ukai Exp $ */
/*
* w3m: WWW wo Miru utility
*
@@ -99,7 +99,6 @@ void bzero(void *, int);
#define PIPEBUFFERNAME "*stream*"
#define CPIPEBUFFERNAME "*stream(closed)*"
#ifdef USE_DICT
-#define DICTCMD "w3mdict"
#define DICTBUFFERNAME "*dictionary*"
#endif /* USE_DICT */
@@ -860,6 +859,10 @@ global char *pauth init(NULL);
global Str proxy_auth_cookie init(NULL);
global int UseExternalDirBuffer init(TRUE);
global char *DirBufferCommand init("file:///$LIB/dirlist" CGI_EXTENSION);
+#ifdef USE_DICT
+global int UseDictCommand init(FALSE);
+global char *DictCommand init("file:///$LIB/w3mdict" CGI_EXTENSION);
+#endif /* USE_DICT */
global int ignore_null_img_alt init(TRUE);
global int FoldTextarea init(FALSE);
#define DEFAULT_URL_EMPTY 0