aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xconfig.guess52
-rwxr-xr-xconfig.sub39
-rw-r--r--debian/changelog8
-rw-r--r--functable.tab153
4 files changed, 223 insertions, 29 deletions
diff --git a/config.guess b/config.guess
index 6641456..45bee13 100755
--- a/config.guess
+++ b/config.guess
@@ -1,9 +1,9 @@
#! /bin/sh
# Attempt to guess a canonical system name.
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-# 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
-timestamp='2004-07-19'
+timestamp='2005-04-22'
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -53,7 +53,7 @@ version="\
GNU config.guess ($timestamp)
Originally written by Per Bothner.
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
@@ -203,9 +203,6 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
amiga:OpenBSD:*:*)
echo m68k-unknown-openbsd${UNAME_RELEASE}
exit 0 ;;
- arc:OpenBSD:*:*)
- echo mipsel-unknown-openbsd${UNAME_RELEASE}
- exit 0 ;;
cats:OpenBSD:*:*)
echo arm-unknown-openbsd${UNAME_RELEASE}
exit 0 ;;
@@ -230,18 +227,12 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
mvmeppc:OpenBSD:*:*)
echo powerpc-unknown-openbsd${UNAME_RELEASE}
exit 0 ;;
- pmax:OpenBSD:*:*)
- echo mipsel-unknown-openbsd${UNAME_RELEASE}
- exit 0 ;;
sgi:OpenBSD:*:*)
- echo mipseb-unknown-openbsd${UNAME_RELEASE}
+ echo mips64-unknown-openbsd${UNAME_RELEASE}
exit 0 ;;
sun3:OpenBSD:*:*)
echo m68k-unknown-openbsd${UNAME_RELEASE}
exit 0 ;;
- wgrisc:OpenBSD:*:*)
- echo mipsel-unknown-openbsd${UNAME_RELEASE}
- exit 0 ;;
*:OpenBSD:*:*)
echo ${UNAME_MACHINE}-unknown-openbsd${UNAME_RELEASE}
exit 0 ;;
@@ -328,6 +319,9 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
*:OS/390:*:*)
echo i370-ibm-openedition
exit 0 ;;
+ *:z/VM:*:*)
+ echo s390-ibm-zvmoe
+ exit 0 ;;
*:OS400:*:*)
echo powerpc-ibm-os400
exit 0 ;;
@@ -351,7 +345,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
DRS?6000:unix:4.0:6*)
echo sparc-icl-nx6
exit 0 ;;
- DRS?6000:UNIX_SV:4.2*:7*)
+ DRS?6000:UNIX_SV:4.2*:7* | DRS?6000:isis:4.2*:7*)
case `/usr/bin/uname -p` in
sparc) echo sparc-icl-nx7 && exit 0 ;;
esac ;;
@@ -810,6 +804,9 @@ EOF
i*:UWIN*:*)
echo ${UNAME_MACHINE}-pc-uwin
exit 0 ;;
+ amd64:CYGWIN*:*:*)
+ echo x86_64-unknown-cygwin
+ exit 0 ;;
p*:CYGWIN*:*)
echo powerpcle-unknown-cygwin
exit 0 ;;
@@ -833,6 +830,12 @@ EOF
cris:Linux:*:*)
echo cris-axis-linux-gnu
exit 0 ;;
+ crisv32:Linux:*:*)
+ echo crisv32-axis-linux-gnu
+ exit 0 ;;
+ frv:Linux:*:*)
+ echo frv-unknown-linux-gnu
+ exit 0 ;;
ia64:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-gnu
exit 0 ;;
@@ -1137,6 +1140,10 @@ EOF
# From seanf@swdc.stratus.com.
echo i860-stratus-sysv4
exit 0 ;;
+ i*86:VOS:*:*)
+ # From Paul.Green@stratus.com.
+ echo ${UNAME_MACHINE}-stratus-vos
+ exit 0 ;;
*:VOS:*:*)
# From Paul.Green@stratus.com.
echo hppa1.1-stratus-vos
@@ -1179,9 +1186,10 @@ EOF
echo ${UNAME_MACHINE}-apple-rhapsody${UNAME_RELEASE}
exit 0 ;;
*:Darwin:*:*)
- case `uname -p` in
+ UNAME_PROCESSOR=`uname -p` || UNAME_PROCESSOR=unknown
+ case $UNAME_PROCESSOR in
*86) UNAME_PROCESSOR=i686 ;;
- powerpc) UNAME_PROCESSOR=powerpc ;;
+ unknown) UNAME_PROCESSOR=powerpc ;;
esac
echo ${UNAME_PROCESSOR}-apple-darwin${UNAME_RELEASE}
exit 0 ;;
@@ -1196,6 +1204,9 @@ EOF
*:QNX:*:4*)
echo i386-pc-qnx
exit 0 ;;
+ NSE-?:NONSTOP_KERNEL:*:*)
+ echo nse-tandem-nsk${UNAME_RELEASE}
+ exit 0 ;;
NSR-?:NONSTOP_KERNEL:*:*)
echo nsr-tandem-nsk${UNAME_RELEASE}
exit 0 ;;
@@ -1249,7 +1260,10 @@ EOF
A*) echo alpha-dec-vms && exit 0 ;;
I*) echo ia64-dec-vms && exit 0 ;;
V*) echo vax-dec-vms && exit 0 ;;
- esac
+ esac ;;
+ *:XENIX:*:SysV)
+ echo i386-pc-xenix
+ exit 0 ;;
esac
#echo '(No uname command or uname output not recognized.)' 1>&2
@@ -1409,7 +1423,9 @@ This script, last modified $timestamp, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from
- ftp://ftp.gnu.org/pub/gnu/config/
+ http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
+and
+ http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
If the version you run ($0) is already up to date, please
send the following data and any information you think might be
diff --git a/config.sub b/config.sub
index ac6de98..87a1ee4 100755
--- a/config.sub
+++ b/config.sub
@@ -1,9 +1,9 @@
#! /bin/sh
# Configuration validation subroutine script.
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-# 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
-timestamp='2004-06-24'
+timestamp='2005-04-22'
# This file is (in principle) common to ALL GNU software.
# The presence of a machine in this file suggests that SOME GNU software
@@ -70,7 +70,7 @@ Report bugs and patches to <config-patches@gnu.org>."
version="\
GNU config.sub ($timestamp)
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
@@ -231,13 +231,14 @@ case $basic_machine in
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
| am33_2.0 \
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
+ | bfin \
| c4x | clipper \
| d10v | d30v | dlx | dsp16xx \
| fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
| ip2k | iq2000 \
- | m32r | m32rle | m68000 | m68k | m88k | mcore \
+ | m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
| mips | mipsbe | mipseb | mipsel | mipsle \
| mips16 \
| mips64 | mips64el \
@@ -262,12 +263,13 @@ case $basic_machine in
| pyramid \
| sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
| sh64 | sh64le \
- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
+ | sparc | sparc64 | sparc64b | sparc86x | sparclet | sparclite \
+ | sparcv8 | sparcv9 | sparcv9b \
| strongarm \
| tahoe | thumb | tic4x | tic80 | tron \
| v850 | v850e \
| we32k \
- | x86 | xscale | xstormy16 | xtensa \
+ | x86 | xscale | xscalee[bl] | xstormy16 | xtensa \
| z8k)
basic_machine=$basic_machine-unknown
;;
@@ -298,7 +300,7 @@ case $basic_machine in
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
| avr-* \
- | bs2000-* \
+ | bfin-* | bs2000-* \
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
| clipper-* | craynv-* | cydra-* \
| d10v-* | d30v-* | dlx-* \
@@ -310,7 +312,7 @@ case $basic_machine in
| ip2k-* | iq2000-* \
| m32r-* | m32rle-* \
| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
- | m88110-* | m88k-* | mcore-* \
+ | m88110-* | m88k-* | maxq-* | mcore-* \
| mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
| mips16-* \
| mips64-* | mips64el-* \
@@ -336,15 +338,16 @@ case $basic_machine in
| romp-* | rs6000-* \
| sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
| shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
+ | sparc-* | sparc64-* | sparc64b-* | sparc86x-* | sparclet-* \
+ | sparclite-* \
| sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
| tahoe-* | thumb-* \
| tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
| tron-* \
| v850-* | v850e-* | vax-* \
| we32k-* \
- | x86-* | x86_64-* | xps100-* | xscale-* | xstormy16-* \
- | xtensa-* \
+ | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
+ | xstormy16-* | xtensa-* \
| ymp-* \
| z8k-*)
;;
@@ -457,6 +460,9 @@ case $basic_machine in
crds | unos)
basic_machine=m68k-crds
;;
+ crisv32 | crisv32-* | etraxfs*)
+ basic_machine=crisv32-axis
+ ;;
cris | cris-* | etrax*)
basic_machine=cris-axis
;;
@@ -486,6 +492,10 @@ case $basic_machine in
basic_machine=m88k-motorola
os=-sysv3
;;
+ djgpp)
+ basic_machine=i586-pc
+ os=-msdosdjgpp
+ ;;
dpx20 | dpx20-*)
basic_machine=rs6000-bull
os=-bosx
@@ -1026,6 +1036,10 @@ case $basic_machine in
basic_machine=hppa1.1-winbond
os=-proelf
;;
+ xbox)
+ basic_machine=i686-pc
+ os=-mingw32
+ ;;
xps | xps100)
basic_machine=xps100-honeywell
;;
@@ -1294,6 +1308,9 @@ case $os in
-kaos*)
os=-kaos
;;
+ -zvmoe)
+ os=-zvmoe
+ ;;
-none)
;;
*)
diff --git a/debian/changelog b/debian/changelog
index 0e993c6..fb6e283 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+w3m (0.5.1-4) unstable; urgency=low
+
+ * GCC 4.0 C++ ABI change.
+ rebuild with libgc-dev 1:6.5-1 for libgc1c2
+ closes: Bug#318160
+
+ -- Fumitoshi UKAI <ukai@debian.or.jp> Thu, 14 Jul 2005 15:10:30 +0000
+
w3m (0.5.1-3) unstable; urgency=low
* fix upgrading /etc/w3m/w3mconfig to /etc/w3m/config
diff --git a/functable.tab b/functable.tab
new file mode 100644
index 0000000..b78b1b2
--- /dev/null
+++ b/functable.tab
@@ -0,0 +1,153 @@
+#include <stdio.h>
+#include "funcname1.h"
+%%
+@@@ FUNCNAME_nulcmd
+ABORT FUNCNAME_quitfm
+ACCESSKEY FUNCNAME_accessKey
+ADD_BOOKMARK FUNCNAME_adBmark
+ALARM FUNCNAME_setAlarm
+BACK FUNCNAME_backBf
+BEGIN FUNCNAME_goLineF
+BOOKMARK FUNCNAME_ldBmark
+CENTER_H FUNCNAME_ctrCsrH
+CENTER_V FUNCNAME_ctrCsrV
+CHARSET FUNCNAME_docCSet
+CLOSE_TAB FUNCNAME_closeT
+CLOSE_TAB_MOUSE FUNCNAME_closeTMs
+COMMAND FUNCNAME_execCmd
+COOKIE FUNCNAME_cooLst
+DEFAULT_CHARSET FUNCNAME_defCSet
+DEFINE_KEY FUNCNAME_defKey
+DELETE_PREVBUF FUNCNAME_deletePrevBuf
+DICT_WORD FUNCNAME_dictword
+DICT_WORD_AT FUNCNAME_dictwordat
+DISPLAY_IMAGE FUNCNAME_dispI
+DOWN FUNCNAME_ldown1
+DOWNLOAD FUNCNAME_svSrc
+DOWNLOAD_LIST FUNCNAME_ldDL
+EDIT FUNCNAME_editBf
+EDIT_SCREEN FUNCNAME_editScr
+END FUNCNAME_goLineL
+ESCBMAP FUNCNAME_escbmap
+ESCMAP FUNCNAME_escmap
+EXEC_SHELL FUNCNAME_execsh
+EXIT FUNCNAME_quitfm
+EXTERN FUNCNAME_extbrz
+EXTERN_LINK FUNCNAME_linkbrz
+FRAME FUNCNAME_rFrame
+GOTO FUNCNAME_goURL
+GOTO_LINE FUNCNAME_goLine
+GOTO_LINK FUNCNAME_followA
+GOTO_RELATIVE FUNCNAME_gorURL
+HELP FUNCNAME_ldhelp
+HISTORY FUNCNAME_ldHist
+INFO FUNCNAME_pginfo
+INTERRUPT FUNCNAME_susp
+ISEARCH FUNCNAME_isrchfor
+ISEARCH_BACK FUNCNAME_isrchbak
+LEFT FUNCNAME_col1L
+LINE_BEGIN FUNCNAME_linbeg
+LINE_END FUNCNAME_linend
+LINE_INFO FUNCNAME_curlno
+LINK_BEGIN FUNCNAME_topA
+LINK_END FUNCNAME_lastA
+LINK_MENU FUNCNAME_linkMn
+LIST FUNCNAME_linkLst
+LIST_MENU FUNCNAME_listMn
+LOAD FUNCNAME_ldfile
+MAIN_MENU FUNCNAME_mainMn
+MARK FUNCNAME__mark
+MARK_MID FUNCNAME_chkNMID
+MARK_URL FUNCNAME_chkURL
+MARK_WORD FUNCNAME_chkWORD
+MENU FUNCNAME_mainMn
+MENU_MOUSE FUNCNAME_menuMs
+MOUSE FUNCNAME_mouse
+MOUSE_TOGGLE FUNCNAME_msToggle
+MOVE_DOWN FUNCNAME_movD
+MOVE_DOWN1 FUNCNAME_movD1
+MOVE_LEFT FUNCNAME_movL
+MOVE_LEFT1 FUNCNAME_movL1
+MOVE_LIST_MENU FUNCNAME_movlistMn
+MOVE_MOUSE FUNCNAME_movMs
+MOVE_RIGHT FUNCNAME_movR
+MOVE_RIGHT1 FUNCNAME_movR1
+MOVE_UP FUNCNAME_movU
+MOVE_UP1 FUNCNAME_movU1
+MSGS FUNCNAME_msgs
+MULTIMAP FUNCNAME_multimap
+NEW_TAB FUNCNAME_newT
+NEXT FUNCNAME_nextBf
+NEXT_DOWN FUNCNAME_nextD
+NEXT_LEFT FUNCNAME_nextL
+NEXT_LEFT_UP FUNCNAME_nextLU
+NEXT_LINK FUNCNAME_nextA
+NEXT_MARK FUNCNAME_nextMk
+NEXT_PAGE FUNCNAME_pgFore
+NEXT_RIGHT FUNCNAME_nextR
+NEXT_RIGHT_DOWN FUNCNAME_nextRD
+NEXT_TAB FUNCNAME_nextT
+NEXT_UP FUNCNAME_nextU
+NEXT_VISITED FUNCNAME_nextVA
+NEXT_WORD FUNCNAME_movRW
+NOTHING FUNCNAME_nulcmd
+NULL FUNCNAME_nulcmd
+OPTIONS FUNCNAME_ldOpt
+PCMAP FUNCNAME_pcmap
+PEEK FUNCNAME_curURL
+PEEK_IMG FUNCNAME_peekIMG
+PEEK_LINK FUNCNAME_peekURL
+PIPE_BUF FUNCNAME_pipeBuf
+PIPE_SHELL FUNCNAME_pipesh
+PREV FUNCNAME_prevBf
+PREV_LINK FUNCNAME_prevA
+PREV_MARK FUNCNAME_prevMk
+PREV_PAGE FUNCNAME_pgBack
+PREV_TAB FUNCNAME_prevT
+PREV_VISITED FUNCNAME_prevVA
+PREV_WORD FUNCNAME_movLW
+PRINT FUNCNAME_svBuf
+QUIT FUNCNAME_qquitfm
+READ_SHELL FUNCNAME_readsh
+REDO FUNCNAME_redoPos
+REDRAW FUNCNAME_rdrwSc
+REG_MARK FUNCNAME_reMark
+REINIT FUNCNAME_reinit
+RELOAD FUNCNAME_reload
+RESHAPE FUNCNAME_reshape
+RIGHT FUNCNAME_col1R
+SAVE FUNCNAME_svSrc
+SAVE_IMAGE FUNCNAME_svI
+SAVE_LINK FUNCNAME_svA
+SAVE_SCREEN FUNCNAME_svBuf
+SEARCH FUNCNAME_srchfor
+SEARCH_BACK FUNCNAME_srchbak
+SEARCH_FORE FUNCNAME_srchfor
+SEARCH_NEXT FUNCNAME_srchnxt
+SEARCH_PREV FUNCNAME_srchprv
+SELECT FUNCNAME_selBuf
+SELECT_MENU FUNCNAME_selMn
+SETENV FUNCNAME_setEnv
+SET_OPTION FUNCNAME_setOpt
+SHELL FUNCNAME_execsh
+SHIFT_LEFT FUNCNAME_shiftl
+SHIFT_RIGHT FUNCNAME_shiftr
+SOURCE FUNCNAME_vwSrc
+STOP_IMAGE FUNCNAME_stopI
+SUBMIT FUNCNAME_submitForm
+SUSPEND FUNCNAME_susp
+TAB_GOTO FUNCNAME_tabURL
+TAB_GOTO_RELATIVE FUNCNAME_tabrURL
+TAB_LEFT FUNCNAME_tabL
+TAB_LINK FUNCNAME_tabA
+TAB_MENU FUNCNAME_tabMn
+TAB_MOUSE FUNCNAME_tabMs
+TAB_RIGHT FUNCNAME_tabR
+UNDO FUNCNAME_undoPos
+UP FUNCNAME_lup1
+VERSION FUNCNAME_dispVer
+VIEW FUNCNAME_vwSrc
+VIEW_BOOKMARK FUNCNAME_ldBmark
+VIEW_IMAGE FUNCNAME_followI
+WHEREIS FUNCNAME_srchfor
+WRAP_TOGGLE FUNCNAME_wrapToggle