aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--file.c2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5e43af3..3ca24a2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+w3m (0.5.1-5.1) unstable; urgency=high
+
+ * NMU by the Security Team:
+ * Fix format string vulnerability in display of SSL certificates.
+ (No CVE ID yet) (Closes: #404564)
+
+ -- Moritz Muehlenhoff <jmm@debian.org> Tue, 26 Dec 2006 18:49:26 +0100
+
w3m (0.5.1-5) unstable; urgency=low
* fix FTBFS on GNU/kFreeBSD (due to unsatisfied Build-Depends on libgpmg1-dev)
diff --git a/file.c b/file.c
index d6d415d..dacd73a 100644
--- a/file.c
+++ b/file.c
@@ -7973,7 +7973,7 @@ inputAnswer(char *prompt)
ans = inputChar(prompt);
}
else {
- printf(prompt);
+ printf("%s", prompt);
fflush(stdout);
ans = Strfgets(stdin)->ptr;
}