aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 29370a4..a2ee3dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,8 +97,10 @@ if test x"$enable_mouse" = xyes; then
AC_CHECK_LIB(gpm, Gpm_Open, [AC_DEFINE(USE_GPM)
W3M_LIBS="$W3M_LIBS -lgpm"])
AC_SUBST(USE_SYSMOUSE)
- AC_TRY_CPP([#include <machine/console.h>
- MOUSE_GETINFO], [AC_DEFINE(USE_SYSMOUSE)])
+ AC_TRY_CPP([#include <sys/consio.h>
+ MOUSE_GETINFO], [AC_DEFINE(USE_SYSMOUSE)],
+ [AC_TRY_CPP([#include <machine/console.h>
+ MOUSE_GETINFO], [AC_DEFINE(USE_SYSMOUSE)])])
fi
AC_SUBST(AUXBIN_TARGETS)
AC_W3M_TERMLIB