aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control2
-rw-r--r--debian/postinst27
-rw-r--r--debian/preinst21
4 files changed, 36 insertions, 28 deletions
diff --git a/debian/changelog b/debian/changelog
index 894cf4b..0e993c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+w3m (0.5.1-3) unstable; urgency=low
+
+ * fix upgrading /etc/w3m/w3mconfig to /etc/w3m/config
+ closes: Bug#242577
+
+ -- Fumitoshi UKAI <ukai@debian.or.jp> Fri, 3 Sep 2004 02:27:43 +0900
+
+w3m (0.5.1-2) unstable; urgency=medium
+
+ * rebuilt with new version of libgdk-pixbuf-dev
+ to build againt with libtiff4
+
+ -- Fumitoshi UKAI <ukai@debian.or.jp> Fri, 6 Aug 2004 01:23:48 +0900
+
w3m (0.5.1-1) unstable; urgency=low
* new upstream version
diff --git a/debian/control b/debian/control
index e607c08..f36955f 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: w3m
Section: text
Priority: standard
Maintainer: Fumitoshi UKAI <ukai@debian.or.jp>
-Build-Depends: libgc-dev, libncurses5-dev, libgpmg1-dev [!hurd-i386], zlib1g-dev, libssl-dev, debhelper (>= 3.0.0), gawk | awk, libgdk-pixbuf-dev, autotools-dev
+Build-Depends: libgc-dev, libncurses5-dev, libgpmg1-dev [!hurd-i386], zlib1g-dev, libssl-dev, debhelper (>= 3.0.0), gawk | awk, libgdk-pixbuf-dev (>= 0.22.0-5), autotools-dev
Standards-Version: 3.6.1
Package: w3m
diff --git a/debian/postinst b/debian/postinst
index 74caddf..1ba8910 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -11,12 +11,27 @@ case "$1" in
/usr/bin/w3m 25 \
--slave /usr/share/man/man1/www-browser.1.gz www-browser.1.gz \
/usr/share/man/man1/w3m.1.gz
- # Remove the conffile with the wrong location (the binary never used
- # it) that may be present from an older version.
- # (In our preinst, we've already ensured the sysadmin had a chance
- # of preserving any configuration made in it)
- rm -f /etc/w3m/w3mconfig
- ;;
+ # upgrade old config file to new config file
+ if test -e /etc/w3m/w3mconfig; then
+ mv -f /etc/w3m/w3mconfig /etc/w3m/w3mconfig.dpkg-tmp
+ tmp=$(tempfile -p w3m.subst.)
+ trap "rm -f $tmp" 0 1 2 15
+ while read opt val
+ do
+ val0=$(sed -ne 's/^'$opt'[[:space:]]*//p' /etc/w3m/w3mconfig.dpkg-tmp)
+ if [ "$val0" != "" ] && [ "$val" != "$val0" ]; then
+ echo 's/^'$opt'[[:space:]]*.*/'$opt' '$val0'/' >> $tmp
+ fi
+ done < /etc/w3m/config
+ if test -s $tmp; then
+ mv -f /etc/w3m/config /etc/w3m/config.dpkg-tmp
+ sed -f $tmp /etc/w3m/config.dpkg-tmp > /etc/w3m/config
+ rm -f $tmp
+ rm -f /etc/w3m/config.dpkg-tmp
+ fi
+ rm -f /etc/w3m/w3mconfig /etc/w3m/w3mconfig.dpkg-tmp
+ fi
+ ;;
*)
esac
diff --git a/debian/preinst b/debian/preinst
deleted file mode 100644
index 274d592..0000000
--- a/debian/preinst
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh -e
-
-case "$1" in
- install|upgrade)
- # Older versions of this package had the conffile in the wrong
- # location (the w3m binary didn't use it). Copy it if its there,
- # so any customisation done there can be preserved. We actually
- # get rid of the wrong file in our postinst.
- if dpkg --compare-versions "$2" lt-nl "0.4.2-1.1"; then
- if test -e /etc/w3m/w3mconfig; then
- if ! test -e /etc/w3m/config; then
- cp -a /etc/w3m/w3mconfig /etc/w3m/config
- fi
- fi
- fi
- ;;
- *)
-esac
-
-#DEBHELPER#
-