Subject: Add support for single quoted meta refresh URL
From: Paul Boekholt
Bug: https://sourceforge.net/p/w3m/patches/53/
--- w3m.orig/file.c 2007-05-23 17:06:05.000000000 +0200
+++ w3m/file.c 2008-09-06 08:46:00.000000000 +0200
@@ -4240,15 +4240,15 @@ getMetaRefreshParam(char *q, Str *refres
while (*q) {
if (!strncasecmp(q, "url=", 4)) {
q += 4;
- if (*q == '\"') /* " */
+ if (*q == '\"' || *q == '\'') /* " or ' */
q++;
r = q;
while (*r && !IS_SPACE(*r) && *r != ';')
r++;
s_tmp = Strnew_charp_n(q, r - q);
- if (s_tmp->ptr[s_tmp->length - 1] == '\"') { /* "
- */
+ if (s_tmp->ptr[s_tmp->length - 1] == '\"' /* " */
+ || s_tmp->ptr[s_tmp->length - 1] == '\'') { /* ' */
s_tmp->length--;
s_tmp->ptr[s_tmp->length] = '\0';
}