aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorterminaldweller <thabogre@gmail.com>2022-11-24 13:12:51 +0000
committerterminaldweller <thabogre@gmail.com>2022-11-24 13:12:51 +0000
commitda6482ffeba391e185ca47b60ffb4b21f644eb95 (patch)
tree1d16ec166679784255f6d4e29c8d2e2bc6976367 /CMakeLists.txt
parentfix for the travis badge. [ci skip] (diff)
downloadcgrep-da6482ffeba391e185ca47b60ffb4b21f644eb95.tar.gz
cgrep-da6482ffeba391e185ca47b60ffb4b21f644eb95.zip
llvm/clang 16 support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18a1c9b..ce0a106 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,6 +56,10 @@ endif()
target_link_libraries(cgrep ${LLVM_SYS_LIBS})
target_link_libraries(cgrep ${LLVM_LIBS})
+if(LLVM_PACKAGE_VERSION VERSION_EQUAL "16.0.0" OR LLVM_PACKAGE_VERSION VERSION_GREATER "16.0.0")
+ target_link_libraries(cgrep clangSupport)
+endif()
+
include_directories("${PROJECT_SOURCE_DIR}/cfe-extra")
target_include_directories(cgrep PUBLIC "${PROJECT_BINARY_DIR}" "${PROJECT_SOURCE_DIR/cfe-extra}")