aboutsummaryrefslogtreecommitdiffstats
path: root/useragents/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <devi@terminaldweller.com>2025-05-09 14:53:09 +0000
committerterminaldweller <devi@terminaldweller.com>2025-05-09 14:53:09 +0000
commitcf5499db368a1cb52ab734d204f08bbcc114a890 (patch)
tree03e4c28a170a5c2318093e6a417fde9830ab5061 /useragents/pyproject.toml
parentnow using the options for the google models again (diff)
downloadmilla-main.tar.gz
milla-main.zip
addes user agents. added aliases.HEADmain
Diffstat (limited to 'useragents/pyproject.toml')
-rw-r--r--useragents/pyproject.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/useragents/pyproject.toml b/useragents/pyproject.toml
new file mode 100644
index 0000000..8777262
--- /dev/null
+++ b/useragents/pyproject.toml
@@ -0,0 +1,31 @@
+[project]
+name = "milla"
+version = "0.1.0"
+description = ""
+authors = [
+ {name = "terminaldweller",email = "devi+github@terminaldweller.com"}
+]
+license = {text = "GPL-3.0"}
+readme = "README.md"
+requires-python = ">=3.13"
+dependencies = [
+ "openai-agents (>=0.0.4,<0.0.5)",
+ "fastapi (>=0.115.11,<0.116.0)",
+ "uvicorn (>=0.34.0,<0.35.0)",
+ "pydantic (>=2.11.3,<3.0.0)",
+ "playwright (>=1.52.0,<2.0.0)"
+]
+
+[tool.poetry]
+package-mode = false
+
+[tool.poetry.group.dev.dependencies]
+ruff = "^0.11.0"
+black = "^25.1.0"
+mypy = "^1.15.0"
+pylint = "^3.3.5"
+bandit = "^1.8.3"
+
+[build-system]
+requires = ["poetry-core>=2.0.0,<3.0.0"]
+build-backend = "poetry.core.masonry.api"