aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <thabogre@gmail.com>2023-03-11 06:40:58 +0000
committerterminaldweller <thabogre@gmail.com>2023-03-11 06:40:58 +0000
commit013c71605185653f735b6a7e6fe622becc03e0fa (patch)
tree65fa452f049078b402cce315e4426130c2858c91 /pyproject.toml
parentfixed the quit bug where we were waiting on cancelled asyncio tasks (diff)
downloadtunneltop-013c71605185653f735b6a7e6fe622becc03e0fa.tar.gz
tunneltop-013c71605185653f735b6a7e6fe622becc03e0fa.zip
we now revive the scheduler if it dies. added a new option to determine which tunnels to auto_start
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index ad57e70..44270e7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "tunneltop"
-version = "0.3.6"
+version = "0.4.0"
description = "A top-like tunnel manager"
authors = ["terminaldweller <devi@terminaldweller.com>"]
license = "GPL-3.0"
@@ -27,3 +27,8 @@ python = "^3.11"
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
+
+[tool.ruff]
+profile = "black"
+target-version = "py311"
+unfixable = ["B", "SIM", "TRY", "RUF"]