aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <thabogre@gmail.com>2023-01-30 13:10:00 +0000
committerterminaldweller <thabogre@gmail.com>2023-01-30 13:10:00 +0000
commit2b4c3d04e302caf5781c5fbccc97c1d130313525 (patch)
tree6b150ea7450d145954a7e2ce9cadc5ac1d5383b6 /pyproject.toml
parentInitial commit (diff)
downloadtunneltop-2b4c3d04e302caf5781c5fbccc97c1d130313525.tar.gz
tunneltop-2b4c3d04e302caf5781c5fbccc97c1d130313525.zip
initial commit
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..d571a99
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,30 @@
+[tool.poetry]
+name = "tunneltop"
+version = "0.1.0"
+description = "A top-like tunnel manager"
+authors = ["terminaldwelelr <devi@terminaldweller.com>"]
+license = "GPL-3.0"
+readme = "README.md"
+homepage = "https://github.com/terminaldweller/tunneltop"
+repository = "https://github.com/terminaldweller/tunneltop"
+keywords = ["tunnel","top","ssh"]
+classifiers = [
+ "Environment :: Console",
+]
+include = [
+ "LICENSE",
+]
+packages = [
+{include = "tunneltop"}
+]
+
+[tool.poetry.dependencies]
+python = "^3.11"
+
+
+[tool.poetry.scripts]
+tunneltop = "tunneltop:main"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"