aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <devi@terminaldweller.com>2023-11-11 05:32:28 +0000
committerterminaldweller <devi@terminaldweller.com>2023-11-11 05:32:28 +0000
commit375c1b983ca5e0d1db6ae77038a5dcd63ae586e2 (patch)
tree34b33c6cbe3106036e9c5d9776fd3ce8e5463b5d /pyproject.toml
parentfixed a bug where an inactive pool would throw exceptions (diff)
downloadvirttop-375c1b983ca5e0d1db6ae77038a5dcd63ae586e2.tar.gz
virttop-375c1b983ca5e0d1db6ae77038a5dcd63ae586e2.zip
fixed some more dynamic change bugs, not sure how to even describe itHEADmain
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e5ead81..cbdf738 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -26,6 +26,13 @@ python = "^3.11"
libvirt-python = "^9.0.0"
defusedxml = "^0.7.1"
+[tool.poetry.group.dev.dependencies]
+black = "^23.11.0"
+ruff = "^0.1.5"
+pylint = "^3.0.2"
+mypy = "^1.7.0"
+bandit = "^1.7.5"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"