aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e5ead81..cbdf738 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -26,6 +26,13 @@ python = "^3.11"
libvirt-python = "^9.0.0"
defusedxml = "^0.7.1"
+[tool.poetry.group.dev.dependencies]
+black = "^23.11.0"
+ruff = "^0.1.5"
+pylint = "^3.0.2"
+mypy = "^1.7.0"
+bandit = "^1.7.5"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"