aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorTatsuya Kinoshita <tats@debian.org>2013-12-14 07:41:00 +0000
committerTatsuya Kinoshita <tats@debian.org>2013-12-14 08:18:54 +0000
commitcb0e11fbaa62c32f192244fcd2328677512e9d42 (patch)
tree2300257d6f3c9b8eac150f531e0ba0d10c756f33 /debian/rules
parentNew patch 290_closedir.patch to fix a directory descriptor leak (diff)
downloadw3m-cb0e11fbaa62c32f192244fcd2328677512e9d42.tar.gz
w3m-cb0e11fbaa62c32f192244fcd2328677512e9d42.zip
Use autotools-dev dh addon again (closes: #732086)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 29f9576..46aa8cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,6 +32,7 @@ build-indep:
build-arch: build-stamp
build-stamp:
dh_testdir
+ dh_autotools-dev_updateconfig
test ! -f entity.h || test -f entity.h.debian-bak || cp entity.h entity.h.debian-bak
cd $(builddir) && CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure $(confargs)
cd $(builddir) && LC_ALL=C $(MAKE) OPTS="-Wall -g -DDEBIAN"
@@ -46,6 +47,7 @@ clean:
rm -f $(builddir)/po/*.gmo
rm -f $(builddir)/po/stamp-po
rm -f extract-stamp patch-stamp configure-stamp build-stamp install-stamp
+ dh_autotools-dev_restoreconfig
dh_clean
install: install-stamp