aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorterminaldweller <devi@terminaldweller.com>2024-09-04 23:52:59 +0000
committerterminaldweller <devi@terminaldweller.com>2024-09-04 23:52:59 +0000
commit4c6a07f44d92eb8b50b5d3f922dd7cba4f6cf8eb (patch)
treed3d6d32671990fef6c3e9e4e3e18151b1f359300 /pyproject.toml
parentfixed some bugs (diff)
downloadtunneltop-main.tar.gz
tunneltop-main.zip
added key bindings for going up and down a pageHEADmain
Diffstat (limited to '')
-rw-r--r--pyproject.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 77a9f43..123947d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "tunneltop"
-version = "0.4.4"
+version = "0.4.5"
description = "A top-like tunnel manager"
authors = ["terminaldweller <devi@terminaldweller.com>"]
license = "GPL-3.0"
@@ -24,6 +24,14 @@ tunneltop = "tunneltop.tunneltop:main"
[tool.poetry.dependencies]
python = "^3.11"
+[tool.poetry.group.dev.dependencies]
+openai = "^1.31.2"
+ruff = "^0.4.8"
+mypy = "^1.10.0"
+bandit = "^1.7.8"
+black = "^24.4.2"
+pylint = "^3.2.3"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"