aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 77a9f43..123947d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "tunneltop"
-version = "0.4.4"
+version = "0.4.5"
description = "A top-like tunnel manager"
authors = ["terminaldweller <devi@terminaldweller.com>"]
license = "GPL-3.0"
@@ -24,6 +24,14 @@ tunneltop = "tunneltop.tunneltop:main"
[tool.poetry.dependencies]
python = "^3.11"
+[tool.poetry.group.dev.dependencies]
+openai = "^1.31.2"
+ruff = "^0.4.8"
+mypy = "^1.10.0"
+bandit = "^1.7.8"
+black = "^24.4.2"
+pylint = "^3.2.3"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"